Notices
 

Activity Stream

Filter
Sort By Time Show
Recent Recent Popular Popular Anytime Anytime Last 24 Hours Last 24 Hours Last 7 Days Last 7 Days Last 30 Days Last 30 Days All All Photos Photos Forum Forums Articles Articles
  • ahirbe's Avatar
    04-25-2017, 08:23 AM
    ahirbe replied to a thread Tire Fix? in How to do it..
    I've decided to just get new tires...I found the front tires but am having trouble with finding the rear wheels with tires, I did find these...
    1 replies | 134 view(s)
  • oldskool's Avatar
    04-23-2017, 12:32 PM
    I have an E12s with a "smart charger" that has been failing for a few years now. Overcharges the fronts by a wide margin without fully charging the...
    0 replies | 64 view(s)
  • ahirbe's Avatar
    04-21-2017, 01:21 PM
    ahirbe replied to a thread E8M Controller in How to do it..
    The mower's electrical system is pretty far gone, as there was a literal rats nest under the console. I do not have a wiring diagram yet but assumed...
    2 replies | 155 view(s)
  • Bush_EGT120's Avatar
    04-20-2017, 08:55 PM
    Bush_EGT120 replied to a thread E8M Controller in How to do it..
    Any 36V controller built for Permanent Magnet motors would work. I don't remember the HP rating on that drive motor, but probably wouldn't need to be...
    2 replies | 155 view(s)
  • ahirbe's Avatar
    04-20-2017, 08:25 AM
    ahirbe started a thread E8M Controller in How to do it..
    I am looking to re wire may E8M with a new controller, does anyone have any advice on which controller would work better for this mower?
    2 replies | 155 view(s)
  • ahirbe's Avatar
    04-20-2017, 08:09 AM
    ahirbe started a thread Tire Fix? in How to do it..
    I have the original "Elec-Trak" branded tires on my E8M and I am really wanting to save them. They have significant dry rot cracks and do not hold...
    1 replies | 134 view(s)
  • 1southcarolina's Avatar
    04-04-2017, 05:52 PM
    Another thing to check is the seat switch, a terminal may have come loos or the switch goes bad. This can be an issue as well Chris C.
    2 replies | 472 view(s)
  • Bush_EGT120's Avatar
    04-02-2017, 07:58 PM
    Bush_EGT120 replied to a thread E10M Question in How to do it..
    If I remember correctly, it should be mounted on the front of the transaxle. There is a large mounting plate that bolts the transaxle to the frame,...
    2 replies | 472 view(s)
  • mikek's Avatar
    03-30-2017, 10:27 PM
    mikek started a thread E10M Question in How to do it..
    My E10M suddenly developed a startup problem. I think I have narrowed it down to the "Clutch Switch". Can anyone tell where this is located? If...
    2 replies | 472 view(s)
No More Results